Package com.mobwith.httpmodule
An HTTP+HTTP/2 client for Android and Java applications.
See: Description
-
Class Summary Class Description Address A specification for a connection to an origin server. AsyncTimeout This timeout uses a background thread to take action exactly when the timeout occurs. UnsafeCursor A handle to the underlying data in a buffer. Buffer A collection of bytes in memory. ByteString An immutable sequence of bytes. Cache Caches HTTP and HTTPS responses to the filesystem so they may be reused, saving time and bandwidth. Builder Builds a {@code Cache-Control}mobonRequest header.CacheControl A Cache-Control header with cache directives from a server or client. Builder Builds a configured certificate pinner. CertificatePinner Constrains which certificates are trusted. Challenge An RFC 7617 challenge. CipherSuite TLS cipher suites. ConnectionPool Manages reuse of HTTP and HTTP/2 connections for reduced network latency. Builder ConnectionSpec Specifies configuration for the socket connection that HTTP traffic travels through. Builder Builds a cookie. Cookie An RFC 6265 Cookie. Credentials Factory for HTTP authorization credentials. DeflaterSink A sink that uses DEFLATE to compress data written to another source. Dispatcher Policy on when async requests are executed. EventListener Listener for metrics events. Builder FormBody ForwardingSink A Sink which forwards calls to another. ForwardingSource A Source which forwards calls to another. ForwardingTimeout A Timeout which forwards calls to another. GzipSink A sink that uses GZIP to compress written data to another sink. GzipSource A source that uses GZIP to decompress data read from another source. Handshake A record of a TLS handshake. HashingSink A sink that computes a hash of the full stream of bytes it has accepted. HashingSource A source that computes a hash of the full stream of bytes it has supplied. Builder Headers The header fields of a single HTTP message. Builder HttpUrl A uniform resource locator (URL) with a scheme of either {@code http}or{@code https}.InflaterSource A source that uses DEFLATEto decompress data read from another source. MediaType An RFC 2045 Media Type, appropriate to describe the content type of an HTTP mobonRequest or response body. Builder MobonOkHttpClient MobonOkio Essential APIs for working with MobonOkio. Builder MobonRequest An HTTP mobonRequest. Builder MobonResponse An HTTP response. Part Builder MultipartBody An RFC 2387-compliant mobonRequest body. Options An indexed set of values that may be read with select. Pipe A source and a sink that are attached. RequestBody ResponseBody A one-shot stream from the origin server to the client application with the raw bytes of the response body. Route The concrete route used by a connection to reach an abstract origin server. Timeout A policy on how much time to spend on a task before giving up. Utf8 Okio assumes most applications use UTF-8 exclusively, and offers optimized implementations of common operations on UTF-8 strings. WebSocketListener -
Interface Summary Interface Description Authenticator Responds to an authentication challenge from either a remote web server or a proxy server. BufferedSink A sink that keeps a buffer internally so that callers can do small writes without a performance penalty. BufferedSource A source that keeps a buffer internally so that callers can do small reads without a performance penalty. Factory Call A call is a mobonRequest that has been prepared for execution. Callback Connection The sockets and streams of an HTTP, HTTPS, or HTTPS+HTTP/2 connection. CookieJar Provides policy and persistence for HTTP cookies. Dns A domain name service that resolves IP addresses for host names. Factory Warning: This is a non-final API. Chain Interceptor Observes, modifies, and potentially short-circuits requests going out and the corresponding responses coming back in. Sink Receives a stream of bytes. Source Supplies a stream of bytes. Factory WebSocket A non-blocking interface to a web socket. -
Enum Summary Enum Description Protocol Protocols that OkHttp implements for ALPN selection. TlsVersion Versions of TLS that can be offered when negotiating a secure socket.